AnsweredAssumed Answered

Custom mkw21d512 board not programming

Question asked by Adam Rea on Aug 4, 2015
Latest reply on Aug 10, 2015 by Jorge_Gonzalez

I am getting the "Kinetis (connect): Timeout while unsecuring device. Erase never starts; Kinetis (connect): Failed to unsecure the Kinetis device." error when I try to program my chip.  Ironically, this is a re-spin of a board to fix the RF power domain issue I had (one VERY small edit to the PCB) and the old version just fired up and programmed with no issues.  Looking at the signals all of them look right except the resetb which never goes high.  With the board plugged into the jlink, the orange LED only lights when I power my board.  There is no short to ground (or adjacent pins) on resetb.  A pullup resistor (10k) makes no difference.  I can short the resetb line to V3 and it moves up to that level freely (thus supporting no short to ground.)   

 

I have been through the archives and tried the jlink commander unlock kinetis command. No luck.  I have held reset low myself, started the command and released the line.  No luck.  I have RC slowed the resetb pin (10uF || 470R to GND).  No luck.  I have tried the jlink commander 'scripts' for the k20 and k60 that I have found.  No luck.  This is clearly an MCU issue (as evidenced by the resetb pulling low only when powered) but I am at a loss to get around it.

 

Any suggestions?

 

(schematic included for completeness)

Adam

Outcomes