AnsweredAssumed Answered

How to unsecure K22F

Question asked by Cecylia Wati on Aug 4, 2015
Latest reply on Apr 4, 2018 by Guangyu Li

Hi there,

 

We just recently tried to program our production-version boards (2 kinds) using these K22F chips:

 

MK22FN1M0AVMC12

MK22FN256VDC12

 

As we tried to bringup the boards for the first time, we couldn't download the code image with J-Link (KDS &/ IAR) due to "timeout unsecuring device" (see exact error messages below).

Connecting to J-Link...

J-Link is connected.

Firmware: J-Link OpenSDA 2 compiled Aug  4 2014 13:30:09

Hardware: V1.00

S/N: 621000000

Checking target voltage...

Target voltage: 3.30 V

Listening on TCP/IP port 2331

Connecting to target...ERROR: Kinetis (connect): Timeout while unsecuring device. Erase never starts.

Kinetis (connect): Failed to unsecure Kinetis device.

ERROR: Error while identifying Cortex-M core.

ERROR: Could not connect to target.

Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...

Shutting down...

 

We also tried to unlock the MCU using J-Link Commander tool, but failed as well with similar messages.


We followed different posts, for example this one: How to unlock a secured Freescale Kinetis L chip

It didn't work.  But, the chip is different so I'm wondering if there's another set of steps for K22F.

 

it seems like 22F is a newer board and there's no exact help on the forum for this.

 

 

Thanks,

Cecylia

Outcomes