AnsweredAssumed Answered

Linux kernel 3.13 blocks PIT interrupt on M4 on PCM052

Question asked by mpfgregory on Aug 3, 2015
Latest reply on Aug 5, 2015 by mpfgregory

I have a PIT running every millisecond on my Cortex-M4. This works fine while a Linux with kernel 3.0 is running on the A5. However, after switching to kernel 3.13 the PIT interrupt on the M4 is not triggered anymore.

 

When I enable the PIT in Linux(

System Type-> Freescale i.MX family-> Freescale i.MX support->Vybrid Family VF610 support->Clocksource for scheduler clock (Use PIT timer)

) the interrupt is also triggered on the M4, but Linux crashes regularly. The shell simply doesn't react anymore. I guess it doesn't like that the scheduler clock is used by someone else.

 

How can I prevent Linux from disabling interrupts that it doesn't use? Linux should only touch the registers of the interrupts it uses and leave all other vectors to the M4.

Outcomes