AnsweredAssumed Answered

Has anyone verified PCI driver on yocto 3.14.28-1.0.1 branch?

Question asked by ban yeer on Aug 1, 2015
Latest reply on Sep 7, 2015 by Philip Downer

Hi,

The hardware we are using is imx6qsabreauto, and previously we can run our device driver successfully on 3.10.17 branch.

Recently we try to update the linux from 3.10.17 to 3.14.28, and the branch we try to use is following,

repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-3.14.28-1.0.1_patch

 

MACHINE=imx6qsabreauto source fsl-setup-release.sh –b build-x11 –e x11

 

 

When we try to load the device driver on 3.14.28, we found request_irq is failed when module_init.

I tried to compare the log between 3.10.17 and 3.14.28,  and found the irq number for PCI device is difference.

 

[3.10.17]

pci 0000:00:00.0: fixup irq: got 155                             
pci 0000:00:00.0: assigning IRQ 155                              
pci 0000:01:00.0: fixup irq: got 155                             
pci 0000:01:00.0: assigning IRQ 155                              

       

[3.14.28]                                                        

pci 0000:00:00.0: fixup irq: got 20                              
pci 0000:00:00.0: assigning IRQ 20                               
pci 0000:01:00.0: fixup irq: got 20                              

pci 0000:01:00.0: assigning IRQ 20

 

later in 3.14.28, when the device driver try to request_irq of 20, it returns failure.

My question is that does anyone has verified the PCI driver on 3.14.28 branch?

 

 

Thanks,

Banyeer

Outcomes