AnsweredAssumed Answered

33905 / SBC Issue: CAN RXD Pin will never assert low, stuck at 3.3V whenever SBC powered

Question asked by slowrobotahead on Jul 31, 2015
Latest reply on Aug 5, 2015 by Jose Alberto Reyes Morales

I'm not using the development kit. Jumped right in to using my own board. MCZ33905S, 3.3V version, hooked up as the main power supply to my board. I have the external PNP, SPI, and all other functions seem to be working. Watchdog, CAN Mode, various settings, 5V VReg, all appear to work as expected.

 

Issue WAS - The CAN RXD line between the SBC and Micro will never go low. It's "stuck" at 3.3V exactly. I can watch the scope and on the CAN+/- lines I can see differential behavior as expected, but this is never "passed" on to the RXD line, it just sits at a solid 3.3V. CAN TX line is also at 3.3V resting but the micro can assert this low as should be the case.

 

-SOLVED- ... Well... I was having two issues in regards to the title. One is that the cap for my split termination was 50nF not 5nF, this was bad. And also some jerk (me) had the wrong pinout for my CAN diagnostic cable, so + and - were switched which I had checked multiple times, but not before fixing the first error. So... I feel dumb. However.... I am still having a fairly troubling issue with the SAFE pin/line that I discovered while diagnosing this CAN error . If anyone can reply on that, now in bold below, I'd appreciate it. Otherwise, I'll make a new post and mark this as answered. Embarrassed.

 

Tried:

- turning 5VReg off - no effect

- took away the SPLIT Biasing and am just using two 60ohm resistors between +/- - no effect

- Tried CAN Modes 0, 1, 2, and 3 - no effect

- Changed micro from internal CAN RX Pullup to just regular input - no effect

- Change CAN RX Pin from input to output and asserted low (not a good idea, I know) - effect is almost exactly .5V on the line

- Various settings via SPI - no effect

- Setting micro's RX pin to low has no effect on other line's voltages like 3.3V, CAN TX, or etc.

 

 

 

The only other bits of information that might be relevant is that after initialization of the SBC:

 

- SBC during RUN is reporting no recurring errors.

- I do get a VREG/0 device flag error just after my init routine, it's 0x10 on VREG0 which is 5VReg Undervoltage, but once cleared, it's does not come back even when tx/rx of CAN messages.

- Also that using the READ MODE command 0xDD80 always reports (return data 0x1A) that the SAFE driver is set. The SAFE pin is not hooked up in my circuit. Using this command is supposed to clear the bit (LEAVE SAFE) doesn't seem to. I am seeing no indication that I am in SAFE mode. The SBC will suffer multiple resets during any breakpoints because I am also not using DEBUG mode, so WD expires. Using Debug resistor of 2k or so to keep VDD on so that on release of the micro from reset, it can re-initialize via SPI

 

Any information that anyone has as to why I may be "stuck" in SAFE would be exceptionally helpful!

Outcomes