AnsweredAssumed Answered

Using USB MultiLink in Kinetis Design Studio 3 with MK02 microcontroller and getting error "System Tried To Join A Dreive To A Directory On A Joined Drive."

Question asked by rampsr on Jul 30, 2015
Latest reply on Aug 3, 2015 by Carlos_Mendoza

Background:

Had always used CodeWarrior 10.3 with a PE Micro Multilink Universal FX for my MKL05Z. I don't use the EVAL boards. Using my own PCBs with the Vdd, Vss, CLK, DIO, RESET pins to program microcontroller during testing. Final product uses a pre-programmer.

 

Just recently: I am migrating over to the MK02 microcontroller. I downloaded Kinetis Design Studio 3. I designed a test PCB and have the Same pins connected as above to my USB MultiLink FX.

 

Problem:

I am unable to communicate with the USB MultiLink.

 

I choose FLASH FROM FILE.

Then the GDB PEMICRO INTERFACE DEBUGGING configuration. ( I am not using OpenOCD ore the SEGGER)

 

 

Then after a timeout I get the following error:

 

I have never dealt with using a GDB or this "LocalHost" environment since CodeWarrior 10.3 was not using a local server.

 

In all honesty, I would be happy with the ability to simply FLASH the .ELF file to the microcontroller without having to deal with debugging or servers. Is there a way I can simply send the file to the microcontroller without all this hassle?

 

Anyhow, I'd like to get my project going and I am burning company time trying to fiddle around with simply trying to get the development software working so I can begin testing my devices...

 

If anyone provides a solution and/or questions, please assume I don't know my @^# (rear end) from a hole in the ground and guide me to where I should look for certain items.

 

UPDATED INFORMATION:

I set up a dummy project to program my existing MKL05 Kinetis microcontroller. Everything worked fine. Flashing the part was successful. One thing to note however: When setting up the project, the MKL05 is unable to use the KSDK 1.2.0, so I disabled it all together and only had Processor Expert selected.

 

As for the MK02 (The one I'm trying to get working), when I set up the project, I am not able to deselect the KSDK option and still be able to use Processor Expert. See the image below.

 

Am I the only one having the problem because it's not like I went in and changed a whole bunch of custom configurations. I simply installed the software, installed the updates, and tried to build a project and program the microcontroller...

Outcomes