AnsweredAssumed Answered

download program to emmc failed(error -110)

Question asked by 杰 胡 on Jul 28, 2015

     There is a IMX6Q board designed by ourself.  We  download program to emmc by MFG tools,but always failed,the log from debug uart is:

UTP: sending Success to kernel for command $ ls /dev/*.

utp_poll: pass returned.

UTP: received command '$ dd if=/dev/zero of=/dev/mmcblk0 bs=512 seek=1536 count=16'

UTP: executing "dd if=/dev/zero of=/dev/mmcblk0 bs=512 seek=1536 count=16"

16+0 records in

16+0 records out

8192 bytes (8.0KB) copied, 0.000210 seconds, 37.2MB/s

UTP: sending Success to kernel for command $ dd if=/dev/zero of=/dev/mmcblk0 bs=512 seek=1536 count=16.

utp_poll: pass returned.

UTP: received command 'send'

UTP: sending Success to kernel for command send.

UTP: received command '$ dd if=$FILE of=/dev/mmcblk0 bs=512 seek=2 skip=2'

UTP: executing "dd if=$FILE of=/dev/mmcblk0 bs=512 seek=2 skip=2"

891+1 records in

891+1 records out

456224 bytes (445.5KB) copied, 0.006041 seconds, 72.0MB/s

UTP: sending Success to kernel for command $ dd if=$FILE of=/dev/mmcblk0 bs=512 seek=2 skip=2.

mmcblk0: error -110 sending stop command, original cmd response 0x2000900, card status 0x2400900

mmcblk0: error -110 transferring data, sector 0, nr 8, cmd response 0x2000900, card status 0x0

mmcblk0: retrying using single block read

utp_poll: pass returned.

UTP: received command 'send'

UTP: sending Success to kernel for command send.

UTP: received command '$ dd if=$FILE of=/dev/mmcblk0 bs=1M seek=1 conv=fsync'

UTP: executing "dd if=$FILE of=/dev/mmcblk0 bs=1M seek=1 conv=fsync"

2+1 records in

2+1 records out

2799007 bytes (2.7MB) copied, 0.019641 seconds, 135.9MB/s

UTP: sending Success to kernel for command $ dd if=$FILE of=/dev/mmcblk0 bs=1M seek=1 conv=fsync.

utp_poll: pass returned.

UTP: received command 'send'

UTP: sending Success to kernel for command send.

UTP: received command '$ tar xf $FILE '

UTP: executing "tar xf $FILE "

UTP: sending Success to kernel for command $ tar xf $FILE .

utp_poll: pass returned.

UTP: received command '$ sh mksdcard.sh /dev/mmcblk0'

UTP: executing "sh mksdcard.sh /dev/mmcblk0"

1+0 records in

1+0 records out

1024 bytes (1.0KB) copied, 0.001554 seconds, 643.5KB/s

Warning: /dev/mmcblk0 is not a block device

Disk /dev/mmcblk0: cannot get geometry

 

 

Disk /dev/mmcblk0: 0 cylinders, 255 heads, 63 sectors/track

 

 

sfdisk: ERROR: sector 0 does not have an msdos signature

/dev/mmcblk0: unrecognized partition table type

Old situation:

No partitions found

New situation:

Units = mebibytes of 1048576 bytes, blocks of 1024 bytes, counting from 0

 

 

   Device Boot Start   End    MiB    #blocks   Id  System

/dev/mmcblk0p1         7+     7-     0          0   83  Linux

/dev/mmcblk0p2         0      -      0          0    0  Empty

/dev/mmcblk0p3         0      -      0          0    0  Empty

/dev/mmcblk0p4         0      -      0          0    0  Empty

Warning: partition 1 has size 0 but is not marked Empty

Warning: no primary partition is marked bootable (active)

This does not matter for LILO, but the DOS MBR will not boot this disk.

Successfully wrote the new partition table

 

 

Re-reading the partition table ...

mmcblk0: error -110 transferring data, sector 0, nr 8, cmd response 0x2000900, card status 0x0

end_request: I/O error, dev mmcblk0, sector 0

BLKRRPART: Inappropriate ioctl for device

 

 

If you created or changed a DOS partition, /dev/foo7, say, then use dd(1)

to zero the first 512 bytes:  dd if=/dev/zero of=/dev/foo7 bs=512 count=1

(See fdisk(8).)

mmcblk0: error -110 transferring data, sector 1, nr 7, cmd response 0x2000900, card status 0x0

end_request: I/O error, dev mmcblk0, sector 1

UTP: sending Success to kernel for command $ sh mksdcard.sh /dev/mmcblk0.

utp_poll: pass returned.

UTP: received command '$ mkfs.ext4 -b 4096 -m 0 -U fa83ac94-049e-4777-b184-0a644720ec6d /dev/mmcblk0p1'

UTP: executing "mkfs.ext4 -b 4096 -m 0 -U fa83ac94-049e-4777-b184-0a644720ec6d /dev/mmcblk0p1"

mke2fs 1.41.4 (27-Jan-2009)

Could not stat /dev/mmcblk0p1 --- No such file or directory

 

 

The device apparently does not exist; did you specify it correctly?

UTP: sending Non-success to kernel for command $ mkfs.ext4 -b 4096 -m 0 -U fa83ac94-049e-4777-b184-0a644720ec6d /dev/mmcblk0p1.

utp_poll: exit with status 256

mmcblk0: error -110 transferring data, sector 2, nr 6, cmd response 0x2000900, card status 0x0

end_request: I/O error, dev mmcblk0, sector 2

mmcblk0: error -110 transferring data, sector 3, nr 5, cmd response 0x2000900, card status 0x0

end_request: I/O error, dev mmcblk0, sector 3

mmcblk0: error -110 transferring data, sector 4, nr 4, cmd response 0x2000900, card status 0x0

end_request: I/O error, dev mmcblk0, sector 4

mmcblk0: error -110 transferring data, sector 5, nr 3, cmd response 0x2000900, card status 0x0

end_request: I/O error, dev mmcblk0, sector 5

mmcblk0: error -110 transferring data, sector 6, nr 2, cmd response 0x2000900, card status 0x0

end_request: I/O error, dev mmcblk0, sector 6

mmcblk0: error -110 transferring data, sector 7, nr 1, cmd response 0x2000900, card status 0x0

end_request: I/O error, dev mmcblk0, sector 7

Buffer I/O error on device mmcblk0, logical block 0

........................................

    can anyone give me some suggestion, thank you!!!

Original Attachment has been moved to: ucl2.xml.zip

Outcomes