AnsweredAssumed Answered

Anyone tried to run u-boot under qemu-system-ppc64 on a T1040RDB?

Question asked by Kim Liu on Jul 24, 2015
Latest reply on Aug 17, 2015 by Kim Liu

The Freescale 1.7SDK (yes, I have not yet made the jump to 1.8) has the u-boot-qoriq_2014.07.bb recipe.

 

Within the u-boot source tree, there is a machine/board target of qemu-ppce500, which appears to be the target to use under qemu/KVM for PowerPC.  However, when trying to start a KVM instance with the resulting u-boot image, it appears to immediately freeze/stop.  So I am wondering if anyone has already accomplished this.

 

Notes:

I have tried the following:

   qemu-system-ppc64 -enable-kvm -M ppce500 -nographic -bios u-boot.bin

   qemu-system-ppc64 -enable-kvm -M ppce500 -nographic -pflash u-boot.bin

   qemu-system-ppc64 -enable-kvm -M ppce500 -nographic -kernel u-boot.elf

 

The last line, with the -kernel, is (attempting) to boot the ELF format image of the u-boot binary. The reason for this was I was attempting to connect a remote instance of GDB to QEMU to debug what was happening, and GDB did not like the non-ELF formats.

 

 

Outcomes