AnsweredAssumed Answered

cannot load my VSC7385 firmware

Question asked by Sourabh Das on Jul 23, 2015
Latest reply on Jul 23, 2015 by lunminliang

Hi, I am working on P1020 rdb for my project development. I am using QorIQ-SDK-V1.7 for software development. Earlier I erased my NOR Flash, so my VSC7385 firmware got erased from its location. When I flash my u-boot in the NOR, I get something like "No address specified for VSC7385 microcode. Phy not found", in my u-boot prompt. So I tried to flash my firmware "vsc2bin" into my NOR. I tried the following steps :

 

usb reset

fatload usb 0:1 0x10000000 vsc2bin

protect off 0xef000000 0xef03ffff

erase 0xef000000 0xef03ffff

cp.b 10000000 0xef000000 0x1ff8

protect on all

 

setenv vscfw_addr 0xef000000

saveenv

 

Then I power cycle my board. Now I am getting this in my u-boot prompt :

uploading VSC7385 microcode from ef000000

Phy not found

 

To make sure the firmware is loaded OK, I tried this steps:

cp.b 0xef000000 40000 11000

go 40004

 

After doing this u-boot is getting stuck with following error:

## Starting application at 0x00040004 ...

NIP: 00040008 XER: 20000000 LR: 3FEFB8D0 REGS: 3fdedc50 TRAP: 0700 DAR: 00000000

MSR: 00029200 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 00

 

GPR00: 3FEFB8C0 3FDEDD40 3FDEDF10 00000001 3FDF11B4 3FDF11B4 FFFFFFFF 00000001

GPR08: 00000020 00040004 00000020 3FDEDD40 3FF0FAA0 F0A8AA04 3FFB0214 3FDF11B0

GPR16: 3FF4992C 3FF49264 3FDF11B0 3FDF11A0 3FDF11E0 00000000 00000000 00000000

GPR24: 00000000 3FFB00D8 00000002 3FDF11B0 00040004 00000002 3FF5AB74 3FDF11B4

** Illegal Instruction **

Call backtrace:

3FEFB8C0 3FF15128 3FEFA550 3FEFAD00 3FEFADA8 3FF14148 3FEFB548

3FF38DF4 3FEFB85C 3FEF164C

Program Check Exception

### ERROR ### Please RESET the board ###

 

I worrying is my firmware is correct or not. Anyone please send me the firmware file, so that i could try with it.

Outcomes