AnsweredAssumed Answered

[Yocto 1.0.0] Enable Bluetooth USB Module in iMX6

Question asked by charles huang on Jun 30, 2015
Latest reply on Jul 1, 2015 by igorpadykov

Hi Freescale

 

Question 1. We want to enable Bluetooth USB Module in iMX6 yocto linux.

Yocto  linux version : 3.10.17

BT Module : Atheros AR9462    (bluetooth  module --> ath3k)    USB interface

 

=====   [1] Add bt config in arch/arm/configs/imx_xxx.config        ===========

------------------------------------------------------------------------

@@ -751,7 +751,26 @@

# CONFIG_CAN_SOFTING is not set

# CONFIG_CAN_DEBUG_DEVICES is not set

# CONFIG_IRDA is not set

-# CONFIG_BT is not set

+CONFIG_BT=y

+CONFIG_BT_RFCOMM=y

+CONFIG_BT_RFCOMM_TTY=y

+CONFIG_BT_BNEP=y

+CONFIG_BT_BNEP_MC_FILTER=y

+CONFIG_BT_BNEP_PROTO_FILTER=y

+CONFIG_BT_HIDP=y

+

+#

+# Bluetooth device drivers

+#

+CONFIG_BT_HCIBTUSB=y

+# CONFIG_BT_HCIBTSDIO is not set

+# CONFIG_BT_HCIUART is not set

+# CONFIG_BT_HCIBCM203X is not set

+# CONFIG_BT_HCIBPA10X is not set

+# CONFIG_BT_HCIBFUSB is not set

+CONFIG_BT_HCIVHCI=y

+# CONFIG_BT_MRVL is not set

+CONFIG_BT_ATH3K=y

# CONFIG_AF_RXRPC is not set

CONFIG_WIRELESS=y

CONFIG_WEXT_CORE=y

------------------------------------------------------------------------

=====    [2]  Add firmware about ar3k       ================================

------------------------------------------------------------------------

IMAGE_INSTALL += " linux-firmware-ar3k "

------------------------------------------------------------------------

 

 

Result :

When system boot up, system always show some message.

------------------------------------------------------------

Bluetooth: Patch file not found ar3k/AthrBT_0x01020200.dfu

Bluetooth: Loading patch file failed

ath3k: probe of 1-1:1.0 failed with error -2

------------------------------------------------------------

 

Firmwares(AthrBT_0x01020200.dfu and ramps_0x01020200_40.dfu) are already in lib/firmware/ar3k.

 

Send command "hciconfig -a ".

We can not get any message.

 

Send command "hciconfig hci0 up"

We get some message " Can't get device info: No such device".

 

root@imx6q:~# hciconfig hci0 up

Can't get device info: No such device

ps : The bluetooth usb module  is already enable and test pass in ltib bsp 4.1.0 version.

 

 

Question 2:   Do you have any information about enable Bluetooth USB Module in Android 4.3/4.4 ?

 

Please advise.

Thanks

 

 

Outcomes