AnsweredAssumed Answered

Cannot program the MKE04Z8

Question asked by Grzegorz Mazur on Jun 30, 2015
Latest reply on Jul 24, 2015 by pgo

I am trying to program the MKE04Z8VTG4 (TSSOP16 variant) on our preproduction series boards with no succes). Basic facts are:

 

The board is pretty simple. To sort the problems out I assembled the boards without any components other than the microcontroller and decoupling & filter capacitors (100 nF +10 uF), placed very close to the chip.

The programmer is an FRDM/KL25Z board with SWDCLK jumper cut and wires soldered to my own SWD connector.

The programming cable is about 20 cm long.

I am using two different software/firmware combinations:

- Keil MDK/ARM + CMSIS_DAP firmware app

- USBDM ARM programmer + USBDM OpenSDA v2.1 firmware.

The first board programmed with no problems. I managed to program only 4 boards out of over 25 assembled.

After swapping the microcontrollers between the "good" and "bad" board, the uC from a "good" one can be programmed on a "bad" PCB and the "bad" uC cannot be programmed on a "good" PCB -> the problem should be attributed to the chip, NOT to the board.

 

The programming software correctly detects the chip and displays the message about erase failure (timeout). So no communication problems but rather an error in erase/program algorithm.

The chips are fresh and unused.

Tried two power supply configurations - 2.94 V from FRDM board or 3.3 V - same behavior.

Tried to lower the SWD clock frequency - no difference.

 

Any help will be appreciated.

Outcomes