AnsweredAssumed Answered

QT4.8.6 eglfs Segmentation fault

Question asked by Richard Li on Jun 23, 2015
Latest reply on Sep 30, 2015 by sanjeev sharma

Hi,

I am porting QT to my mx6q custom board, there are some problems with the eglfs.

 

I use the LTIB package L3.0.35_4.1.0_130816_source.tar.gz and QT4.8 with tag v4.8.6(qtproject/qt · GitHub ).

According to Building QT for i.MX6

 

To build LTIB, the ipu,vpu and gpu firmware and libraries has been selected.

To build qt4.8.6, the step is:

① ./configure \

  -opensource -confirm-license -release -shared -qpa -arch arm -verbose \

  -xplatform qws/linux-imx6-g++ -fast -optimized-qmake -pch -opengl es2 -egl \

  -qt-sql-sqlite -qt-libjpeg -qt-zlib -qt-libpng -qt-freetype \

  -no-webkit -no-qt3support -exceptions -no-rpath \

  -make examples -make demos -make libs -nomake docs

 

② make && make install

③ build eglfs and linuxfb libraries.

 

Then copy all the QT files to LTIB rootfs, then boot through NFS. After that, set some QT environment variables, then run the QT examples.

 

Firstly, I run some examples with linuxfb, such as "collidingmice -platform linuxfb", it's ok.

But when I run some opengl examples, such as "hellogl_es2 -platform eglfs", I get error message as following:

 

"Opened display 0x36d844f8

 

Initialized display 1 4

 

Segmentation fault"

 

 

The same error I use the QT5.4.2, all the opengl examples always can't be executed.

 

 

Does any one can help me?

 

Best Regards,

Richard

Outcomes