AnsweredAssumed Answered

FRDM KL46Z Only detected in Bootloader mode

Question asked by Matheus Hentschke on Jun 22, 2015
Latest reply on Jun 24, 2015 by Matheus Hentschke

I'm having issues with my FRDM KL46z and I can't figure out what's happening and why is it happening. I have two boards and both of them are doing the same thing

 

When I plug the USB cable with the reset switch pressed (bootloader mode) the device is properly recognized and windows shows the "storage device" called Bootloader.

I tried with both, the debug SDA software and the and the MSD software (dragging and dropping into the bootloader drive) and when I power cycle the board (unplug and plug again), the board is not detected in any way. The board I was using was working fine till that problem started and the other board was never used (was on the box and I don't even put the headers on it).

 

What I've already tried:

 

- Change the bootloader software using the ones that come in the QSP

- Tried in 2 windows PC's and in 2 Ubuntu 14.04 PC's (the board I was using was working on Ubuntu sending characters by the serial port and the virtual serial port was properly detected by Ubuntu)

- Update the firmware (Downloaded from PEMicro (v111))

- Change to the MSD-DEBUG-FRDM-KL46Z48M_Pemicro_v114.SDA software

 

Any of the listed trials seemed to do anything.

 

I don't know what to do to make the boards work again!

 

If somebody have any ideas on how to fix this issues, please help!

 

Thank you

Outcomes