AnsweredAssumed Answered

imx6 board bringup

Question asked by srinivasaporam on Jun 19, 2015
Latest reply on Jun 22, 2015 by Yuri Muhin

Hi,

We have got imx6 board which has just come after assembly. We would like to port linux to this new machine through SD card for which we are following the yocto training (https://community.freescale.com/docs/DOC-94849).

 

We have followed all the instructions, but nothing is happening in the board. the board is not bootingup or any messages are not been displayed on the monitor connected to imx6 board through HDMI.

 

when we go to the following folder :

 

/fsl-community-bsp/build/tmp/deploy/images/imx6qsabresd

 

and check the files in imx6sabresd by issueing ls command it lists out:

 

core-image-base-imx6qsabresd-20150615132616.rootfs.ext3

core-image-base-imx6qsabresd-20150615132616.rootfs.sdcard

core-image-base-imx6qsabresd-20150615132616.rootfs.tar.bz2

core-image-base-imx6qsabresd.ext3

core-image-base-imx6qsabresd.sdcard

core-image-base-imx6qsabresd.tar.bz2

fsl-image-gui-imx6qsabresd-20150616053508.rootfs.ext3

fsl-image-gui-imx6qsabresd-20150616053508.rootfs.sdcard

fsl-image-gui-imx6qsabresd-20150616053508.rootfs.tar.bz2

fsl-image-gui-imx6qsabresd.ext3

fsl-image-gui-imx6qsabresd.sdcard

fsl-image-gui-imx6qsabresd.tar.bz2

modules--3.0.35-r37.14-imx6qsabresd-20150615132616.tgz

modules-imx6qsabresd.tgz

print

README_-_DO_NOT_DELETE_FILES_IN_THIS_DIRECTORY.txt

u-boot.imx

u-boot-imx6qsabresd.imx

u-boot-imx6qsabresd-v2013.10-r0.imx

uImage

uImage--3.0.35-r37.14-imx6qsabresd-20150615132616.bin

uImage-imx6qsabresd.bin

 

 

 

We think we are missing some points:

 

in task#4 in the yocto training, it is been suggested as below:

 

Deploy the sdcard image:

 

$ sudo dd if=fsl-image-gui-imx6qsabresd.sdcard of=/dev/sdX bs=1M

 

when i run the command ($sudo fdisk -l) in my host PC(Ubuntu 14.04) by connecting sd card,

 

it is indicating that my sd card is /dev/mmcblk0p1. So we are changing the command to

 

$ sudo dd if=fsl-image-gui-imx6qsabresd.sdcard of=/dev/mmcblk0p1 bs=1M

 

is this correct?????

 

 

Or, deploy the ext3 rootfs

 

$ sudo dd if=fsl-image-gui-imx6qsabresd.ext3 of=/dev/sdX2 bs=1M

 

this command is changed to :

 

$ sudo dd if=fsl-image-gui-imx6qsabresd.ext3 of=/dev/mmcblk0p1 bs=1M

 

is this correct???

 

 

Or deploy only the tar.bz rootfs

 

$ sudo mount /dev/sdX2 /mnt/card

$ sudo tar xf imagename-imx53qsb.tar.bz2 -C /mnt/card

 

these commands are changed to :

 

$sudo mount /dev/mmcblk0p1 /mnt/card

$sudo tar xf fsl-image-gui-imx6qsabresd.tar.bz2 -C /mnt/card

 

are these correct or not???

 

 

In order to deploy only kernel

 

$ sudo cp uImage-3.0.35-r32.10-imx6qsabresd-20130505174618.bin /media/Boot

this command changed to :

$sudo cp uImage--3.0.35-r37.14-imx6qsabresd-20150615132616.bin /media/Boot

 

is this correct???

 

 

In order to  deploy only u-boot

 

$ sudo dd if=u-boot-imx6qsabresd-v2012.10-r3.imx of=/dev/sdX bs=512 seek=2

 

the above command changed to

$sudo dd if=u-boot-imx6qsabresd-v2013.10-r0.imx of=/dev/sdX bs=512 seek=2

 

 

If using HDMI please, modify u-boot environment arguments:

setenv mmcargs "setenv bootargs console=${console},${baudrate} root=${mmcroot} rootwait rw video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24"

We don't know in which file these are to be set and how to set??? we came to know that when the board boots, then we will get uboot console then we need to change the bootargs. but in our case nothing is happening. no display is coming on the monitor which is connected to board through HDMI.

 

 

This is the how sdcards are made by meta-fsl-arm. Of course you can use your own. But double check the u-boot bootenv.

 

 

Plug your sdcard and let the board boot

 

To login: root

 

here in this training material, they are suggesting us to deploy either sdcard image or ext3 rootfs or tar.bz2 root fs or kernel or uboot.

 

But if we want to boot and port OS into the board through SD card. what are all need to be deployed???

 

what are all the mistakes that we are doing??? why we are not getting any display???

 

 

Please help us in resolving the issues...

Outcomes