AnsweredAssumed Answered

Watch dog not refreshing when using KSDK 1.0

Question asked by James Pieterick on Jun 15, 2015
Latest reply on Jun 16, 2015 by David E Seymour

Hi everyone,

 

I am having a problem with the watch dog on my K24 project. It keeps resetting even though I am sure that I am calling WDOG_DRV_Refresh() every 10 milliseconds or less. It resets at its overflow time each time. I have tried 5, 10 and 100 second overflow times.

 

I am passing the following configuration structure to the wdog initialization function:

 

const wdog_user_config_t wdogInit =

{

  .timeoutValue = 5120U,  /* Watchdog overflow time is about 5s */

  .windowValue = 0U,  /* Watchdog window value, 0--disable window function */

  .clockPrescalerValue = kWdogClockPrescalerValueDevide1, /* Watchdog clock prescaler */

  .updateRegisterEnable = true, /* Update register enabled */

  .clockSource = kWdogClockSourceLpoClock, /* Watchdog clock source is LPO 1KHz */

  .workInWaitModeEnable = true, /* Enable watchdog in wait mode */

.workInStopModeEnable = true, /* Enable watchdog in stop mode */

  .workInDebugModeEnable = false, /* Disable watchdog in debug mode */

};

 

I am working in KDS version 1.1.1 and KSDK 1.0. I have tried using processor expert to setup the timer as well as attempting to use the example in the wdog demo code.

 

Do you have any ideas as to what might be wrong?

 

Thanks.

Outcomes