AnsweredAssumed Answered

Trouble getting USB device PHDC demo app working on any freedom board

Question asked by Travis Long on Jun 12, 2015
Latest reply on Sep 3, 2015 by Travis Long

I've now tried running the 'demo' app of the USB device PHDC weighscale app on a FRDM-KL25Z, FRDM-KL26Z, and FRDM-KL46Z boards, all with the same result.  The first problem I notice is that the HealthLink software driver is looking for the VID/PID of "Freescale.DeviceID = "VID_0425&PID_0004"", but the demo app is using the VID of A215.  So I modified the VID in the usb_descriptor.c file and built and ran it again.  Now I notice that the device is actually enumerating as VID 2504, PID 0004.  I think this is strange, but I chalk it up to a simple endianness issue, so I go back to usb_descriptor.c in the demo app and reverse the endianness of the VID/PID and try again.  Now the device enumerates correctly and is associated with the correct driver in device manager.  After launching HealthLink, at first I think that it has failed again because while HealthLink now does 'see' a compatible device, it still lists it as an "Unknown Device".  But while I'm sitting here typing this it did finally take off and work.  

 

Has anyone else tried the USB PHDC demo app and run into anything similar?  Why should I have to make any modification to a 'demo app' at all in order to get this working, even following the "Readme.pdf" instructions step by step?

Outcomes