AnsweredAssumed Answered

L2 switch problem with LAN

Question asked by Jeremy Esquirol on Jun 11, 2015
Latest reply on Jul 20, 2015 by Karina Valencia Aguilar

Hi all,

I'm encountering a very strange issue with the L2_swtich on Vybrid, using linux 3.0, and i've the same problem on our custom board, phytec board and freescale twr board.

All my board are in static IP.

 

My PC is connected to the ETH0 port on board. I connect the ETH1 on a switch in my local network. This switch is connected to a router for internet access.

From my pc, i can ping all members in the local network and i can access to internet.

Here is the problem : I can't acces website ( on other things like ssh or ftp connection) in my LOCAL network.

 

I've a full acces on WAN, i can ping all member in LAN, but it seems like if the data's are too big (or too much datas) from the local network, the switch don't work.

 

I've tried with only 2 board and 1 pc connected : The pc on ETH0 and the second board on ETH1, all with static IP. I'm able to ping both board. I can access the first board embedded website, but i can't access the second...

 

It's like if there is a big set of data in short time, I lost the frames. Does the switch is fast enought?

 

I've also tried to reduce data speed to 10T (i was using Auto Negociation) but it d'ont change anything.

 

Any idea?

Outcomes