AnsweredAssumed Answered

bitbake core-image-x11 fails in do_rootfs for i.MX6Q - Udoo Quad board

Question asked by Angus Galloway Employee on Jun 10, 2015
Latest reply on Jun 12, 2015 by Daiane Angolini

I have built many images for the udoo before such as core-image-base, with settings as per my blog post here.  Ultimately, the problem is this:

 

packagegroup-core-x11-base : Depends: packagegroup-core-x11-utils but it is not going to be installed

W: Unable to read /home/angus/build/tmp/work/udoo_quad-poky-linux-gnueabi/core-image-x11/1.0-r0/apt/apt.conf.d/ - DirectoryExists (2: No such file or directory)

 

In  "/home/angus/build/tmp/work/udoo_quad-poky-linux-gnueabi/core-image-x11/1.0-r0/apt" I have apt.conf, preferences, sources.list, sources.list.rev but no apt.conf.d.

 

 

### LOCAL.CONF ###  MACHINE ??= 'udoo-quad' DISTRO ?= 'poky' PACKAGE_CLASSES ?= "package_deb" IMAGE_INSTALL_append = " canutils" IMAGE_INSTALL_append += " libsocketcan" IMAGE_INSTALL_append += " iproute2"  IMAGE_FSTYPES ?= "ext3 sdcard" EXTRA_IMAGE_FEATURES = "debug-tweaks" USER_CLASSES ?= "buildstats image-mklibs image-prelink" PATCHRESOLVE = "noop" BB_DISKMON_DIRS = "\     STOPTASKS,${TMPDIR},1G,100K \     STOPTASKS,${DL_DIR},1G,100K \     STOPTASKS,${SSTATE_DIR},1G,100K \     ABORT,${TMPDIR},100M,1K \     ABORT,${DL_DIR},100M,1K \     ABORT,${SSTATE_DIR},100M,1K"  CONF_VERSION = "1"  BB_NUMBER_THREADS = '8' PARALLEL_MAKE = '-j 8'  INHERIT += "rm_work"  DL_DIR ?= "${BSPDIR}/downloads/" ACCEPT_FSL_EULA = ""

 

Note that I was using "rm_work" to save disk space, but I have tried building with and without that commented out.
I am attaching the log file.

Original Attachment has been moved to: log.do_rootfs.3922.zip

Original Attachment has been moved to: run.do_rootfs.3922.zip

Outcomes