AnsweredAssumed Answered

iMX535 fails to start

Question asked by Jim Ahlman on Jun 8, 2015
Latest reply on Jun 10, 2015 by igorpadykov

I have run into a weird problem with my design that uses an iMX535. Essentially the processor does not boot (using SD card) after a successful power on cycle and POR. In addition, the crystal fails to start. However, if you simply touch the iMX with your finger it loads U-Boot, Linux, and seems to operate normally after that. Just pressing on the part with a non-conductive tool does not have the same effect.

 

I’ve verified the following:

  • Rail voltages are well within spec (measured at the iMX pins). Using LTC3589-2 PMIC.
  • Power on sequence meets the Freescale spec. POR asserted until ~7mS after last rail voltage is stable.
  • I’m using GPIO for the configuration bits. Voltage levels on these pins meet the spec, and are set to boot from SD card low speed.
  • Crystal is 24 MHz 80 ohms ESR with two 18pF load caps. CL is 10pF for this part, and I’ve tried a few different combinations with the same result.

 

Has anyone seen behavior like this? Any help will be greatly appreciated.

Outcomes