AnsweredAssumed Answered

resume from suspend issue on imx53qsb mainline kernel

Question asked by alexeym on Jun 6, 2015
Latest reply on Jun 11, 2015 by alexeym

Hello all,

 

I'm trying to use on imx53qsb with mc34708 pmic. And stuck with resume from suspend. It stops to resume after 5-15 cycles.(maybe more)

 

WEC7 BSP works fine on the same board.

 

It doesn't matter what IRQ line I'am using to wake up, I tried buttons with

gpio-key,wakeup; in dts, and waking up from ttymxc0 ( debug console)

 

cd /sys/class/tty/ttymxc0/

echo enabled > power/wakeup

 

after some I see

[ 1394.555344] PM: Syncing filesystems ... done.

[ 1394.746289] PM: Preparing system for mem sleep

[ 1394.753918] Freezing user space processes ... (elapsed 0.001 seconds) done.

[ 1394.762553] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.

[ 1394.771342] PM: Entering mem sleep

[ 1394.843168] PM: suspend of devices complete after 67.680 msecs

[ 1394.850220] PM: late suspend of devices complete after 1.061 msecs

[ 1394.857804] PM: noirq suspend of devices complete after 1.340 msecs

[ 1394.864107] Disabling non-boot CPUs ...

And thats it.

Looks like About iMX53 suspend/resume issue  is totally related to my issue. But still nobody solved it?

Outcomes