AnsweredAssumed Answered

Enabling the L2 switch with device tree

Question asked by Dustin D on Jun 3, 2015

Hi,

 

I'm trying to enable the L2 switch (in switch mode) on my PHYTEC phyCORE Vybrid Development Kit (uses the VF610). I've downloaded the 3.13 Kernel from Timesys and applied the patch linux-3.13.9-vybrid-ts2.5.patch. The 3.13 kernel uses a device tree to configure the board and I've attached the dts file I'm using.

 

In the kernel, I changed the two configuration options as outlined here: How to use L2 switch on Vybrid processor ?

 

When I boot I see:

...

400d0000.ethernet supply phy not found, using dummy regulator

fec 400d0000.ethernet (unregistered net_device): Invalid MAC address: 00:00:00:00:00:00

fec 400d0000.ethernet (unregistered net_device): Using random MAC address: 9a:2e:e4:90:25:50

libphy: fec_enet_mii_bus: probed

400d1000.ethernet supply phy not found, using dummy regulator

fec 400d1000.ethernet (unregistered net_device): Invalid MAC address: 00:00:00:00:00:00

fec 400d1000.ethernet (unregistered net_device): Using random MAC address: de:d4:f5:7b:4f:2d

libphy: fec_enet_mii_bus: probed

Ethernet Switch Version 1.0

...

Configuring network interfaces: fec 400d0000.ethernet eth0: Freescale FEC PHY driver [Micrel KSZ8051] (mii_bus:phy_addr=400d0000.etherne:00, irq=-1)

...

libphy: 400d0000.etherne:00 - Link is Up - 100/Full

 

 

Running an ifconfig after boot reveals:

eth0  Link encap:Ethernet  HWaddr 04:2D:F4:05:5A:45
      inet addr:10.11.65.15  Bcast:0.0.0.0  Mask:255.255.0.0
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:110 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:9509 (9.2 KiB)  TX bytes:0 (0.0 B)

 

lo    Link encap:Local Loopback
      inet addr:127.0.0.1  Mask:255.0.0.0
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I have a cable connecting eth0 to my router and I can ping other devices on the network. However, when I plug another device (for example a raspberry pi) into eth1 there is no traffic between the board and the device and the LEDs on eth1 show no activity. Does anyone know how to enable the switch?

Original Attachment has been moved to: pcm052.dts.zip

Outcomes