AnsweredAssumed Answered

Running KDS 2 project in KDS 3 causing compile errors

Question asked by ChrisTango on May 29, 2015
Latest reply on May 29, 2015 by Jorge_Gonzalez

Hi everybody,

 

I created a demo in KDS 2 and a community member tried to import this project in KDS 3.0.0 and recognized that the project is not able to compile.

I tried the same on my side and figured out to have the same issue with this KDS 2 project in KDS 3. Further, I've tried an other project from the internet which was created in KDS 2 and had the same problem to compile in KDS 3.

If I create the project from the ground up in KDS 3 then everything is fine.

 

Here the console. I attached the demo to this message as well.

'Building target: Test_EthLDD.elf'

'Invoking: Cross ARM C++ Linker'

arm-none-eabi-g++ -mcpu=cortex-m4 -mthumb -mfloat-abi=hard -mfpu=fpv4-sp-d16 -O0 -fmessage-length=0 -fsigned-char -ffunction-sections -fdata-sections  -g3 -T "C:/Users/Kleber Gouveia/Desktop/Test_EthLDD/Project_Settings/Linker_Files/ProcessorExpert.ld" -Xlinker --gc-sections -L"C:/Users/Kleber Gouveia/Desktop/Test_EthLDD/Project_Settings/Linker_Files" -Wl,-Map,"Test_EthLDD.map" -nanolibc -o "Test_EthLDD.elf"  ./Sources/Events.o ./Sources/main.o  ./Project_Settings/Startup_Code/startup.o  ./Generated_Code/System/CPU_Init.o ./Generated_Code/System/Peripherals_Init.o ./Generated_Code/System/Vectors.o  ./Generated_Code/Cpu.o ./Generated_Code/CsIO1.o ./Generated_Code/ETH.o ./Generated_Code/IO1.o ./Generated_Code/PE_LDD.o ./Generated_Code/Pins1.o ./Generated_Code/TIMER.o  

arm-none-eabi-g++: error: unrecognized command line option '-nanolibc'

make: *** [Test_EthLDD.elf] Error 1

 

Is this a general bug in KDS 3? Is it known and is there a workaround?

 

Best regards,

Chris

Original Attachment has been moved to: Test_EthLDD.zip

Outcomes