AnsweredAssumed Answered

Audio problem on custom board

Question asked by Andrew Parlane on May 19, 2015
Latest reply on May 27, 2015 by Andrew Parlane

Hi all,

 

I'm trying to get audio working on our new custom board. Starting off testing with aplay and a 16 bit .wav.

 

Unfortunately it fails with:

playback write error (DMA or IRQ trouble?)

aplay: pcm_write:1939: write error: Input/output error

 

The board is modelled after the reference designs and uses the SGTL5000 connected via I2S from the output of AUDMUX3.

 

When I scope the I2S clock line (CSI0_DAT4) it does not wiggle.

 

Looking at the pinmux, I can confirm that those pins are configured to alt 4. (AUDMX3). When I configure them to be GPIO I can wiggle the clock line through sysfs gpio150 - gpio5_22.

 

This worked fine on the previous rev of the board which was a solo core board.

 

My device tree is attached.

 

I've seen a few people posting about this same error message, but they either have no solutions or are due to a different issue.

 

Using linux 3.10.17

I also checked that the SDMA firmware had been loaded correctly.

 

imx-sdma 20ec000.sdma: loaded firmware 1.1

imx-sdma 20ec000.sdma: initialized

 

Any suggestions?

Thanks,

Andrew Parlane

Original Attachment has been moved to: device_tree_rev3_quad.dts.zip

Outcomes