AnsweredAssumed Answered

mfg tool failed for android 4.4.3.

Question asked by THANGAMEENA RAJENDHIRAN on May 14, 2015
Latest reply on May 14, 2015 by Saurabh Patel

Hi, everyone,

 

I am working in sololite platform  custom board.

 

now i downloaded kitkat 4.4.3  it has kernel 3.10.17. i want to flash  emmc .

first i tried with my sololite evk.

in evk there is no emmc so for sdcard  .

1. downloaded mfg tool for 4.4.3.

2. given list name cfg.ini as  SDCard-Android-IMX6SL-EVK.    , mmc=0,1(tried both)

3. using sd2 slot inserted sd card. changed download mode.

4. added img files under android/evk/<.img>

5. executed exe. found hid device

6. its running but failed at partitioning.

7. error as fdisk not regognized.

 

i read the android firmware document. in that the given document is same as like for 4.4.2 mfg tool. in this 4.4.3 the kernel is in device tree format. there are more changes in bsp.

there is no file to compile ram uboot and ram kernel

under uboot/ include/configs/< mx6sl_evk_mfg.h>

kernel/arch/arm/configs/ imx6_updater_defconfig

 

to compile ram uboot and ram kernel

 

kindly help me in this issue

 


 

Outcomes