AnsweredAssumed Answered

Problem with understanding EPD and QT apps on i.MX6 SoloLite

Question asked by Branko Karaklajic on May 11, 2015
Latest reply on Jul 10, 2015 by ajithpv

Hello everyone,

 

This is our first post on this forum, and also first use of Freescale i.MX6SoloLite platform.

 

Few words of history. We are using i.MX6SL-EVK with EPD add on board. All is ok when system is booted from included sdcard for e-INK demo.

 

We managed to compile two different images, with latest Linux and U-Boot releases (rel_imx_3.14.28_1.0.0_ga).

One image is built with Yocto (fsl-image-qt5 with -e fb switch) second one is built with Buildroot (qt5 included and built with linuxfb support). Both images boot successfully to console, and Tux is shown on EPD during linux boot. On both images, we have video=mxcepdcfb:E060SCM passed from u-boot to linux.

 

Description of problems:

We are not able to show anything on display.

With buildroot:

1. We tried to show image on display with fbv <file_name>.

Nothing is shown on display, but when we use fbgrab, we are able to see image in captured fb output.

2. We tried to run qt example (analogclock) and same as above, nothing on display, but clock is shown when image captured with fbgrab.

 

Output of fbset for buildroot:

# fbset

 

 

mode "800x600-0"

        # D: 0.037 MHz, H: 0.041 kHz, V: 0.067 Hz

        geometry 800 600 800 1280 16

        timings 26666667 8 100 4 8 4 1

        accel false

        rgba 5/11,6/5,5/0,0/0

endmode

With Yocto build (fsl-image-qt5)

1. We are able to run mxc_epdc_fb_test form /unit-tests directory, and we are able to see different phases of tests on EPD.

2. When we try to run qt example on this build (analogclock) we are not able to see anything on display, same as for Buildroot image.

 

Output of fbset is same as for Buildroot build.

 

My question is, how to see QT examples on EPD display. Let's say, mentioned analogclock example?

 

Any debug output are available on request. Not sure what to attach in this moment.

 

Our guess is that some steps are missing on our side.

Any help?

 

Thanks
Branko

Outcomes