AnsweredAssumed Answered

How to install KSDK 1.2 support in Pex

Question asked by Adrian Rockall on May 11, 2015
Latest reply on Sep 8, 2015 by Kewal Deshpande

Hi,

 

I have downloaded KSDK 1.2 and tried to follow the instruction for adding support into Pex but I get an error when trying to install the Eclipse update. It say it is missing a dependency as shown below:

Cannot complete the install because one or more required items could not be found.

  Software being installed: KSDK 1.2.0 Eclipse Update 1.0.0.b150420 (com.freescale.processorexpert.ksdk-1.2.0.sp.feature.group 1.0.0.b150420)

  Missing requirement: KSDK 1.2.0 Eclipse Update 1.0.0.b150420 (com.freescale.processorexpert.ksdk-1.2.0.sp.feature.group 1.0.0.b150420) requires 'com.freescale.processorexpert.feature.core.kpsdk.feature.group [1.2.0,2.0.0)' but it could not be found

 

I have searched to try and find the component but had no luck finding it.

First I tried to add it to Pex that already had KSDK 1.1.1 support then I tried to uninstall and install again on a clean Pex.

 

How do I update Pex?

 

Once I have got Pex working what is the best way to update my existing IAR + KSDK 1.1.1 + Pex projects?

 

If I have to move to KDS 3.0 how do I import and upgrade my old IAR + KSDK 1.1.1 projects?

 

Thanks,

Adrian.

Outcomes