AnsweredAssumed Answered

maxcpu's settings in Uboot.

Question asked by kumara bhimeswararao on May 7, 2015
Latest reply on May 12, 2015 by Yuri Muhin

Hi ,

 

I am working on Sabre auto board. There are 4 cpus running on linux kernel.

In  Bootargs i set maxcpus as 1 at Uboot. So that during initial   boot time kernel boots with single CPU to reduce 300ms boot time.

 

Later after mounting the file system using sysfs  i tried to enable the rest of CPU's. But rest of 3 CPU's were not enabled.

 

 

 

Scrip ran :

 

echo 1 > /sys/devices/system/cpu/cpu[123]/online

 

Verified with :

 

cat /proc/cpuinfo

 

 

Regards,

Bhimesh.

Outcomes