AnsweredAssumed Answered

How to enable i2c1 in device tree for vybrid vf50 (interrupts)

Question asked by Sandro Stiller on May 6, 2015
Latest reply on May 14, 2015 by Karina Valencia Aguilar



Hello,

 

I'm trying to enable the 2nd i2c in the device tree for my linux kernel.

I took the entries for the i2c0 and modified them with this result:

 

i2c1: i2c@40067000 {
  #address-cells = <1>;
  #size-cells = <0>;
  compatible = "fsl,vf610-i2c";
  reg = <0x40067000 0x1000>;
  clocks = <&clks VF610_CLK_I2C1>;
  clock-names = "ipg";
  dmas = <&edma0 0 52>,
  <&edma0 0 53>;
  dma-names = "rx","tx";
  status = "disabled";                                                    
}; 
...
...
&i2c1 {
  clock-frequency = <400000>;
  pinctrl-names = "default";
  pinctrl-0 = <&pinctrl_i2c1>;
  status = "okay";
};

 

While starting the kernel prints this message:

 

[

0.171667] imx-i2c 40067000.i2c: can't get irq number

 

I think that I must add an "interrupts" entry, but where can I find the correct number?

 

In my i2c-0 the number 71 was given, in an other device tree i2c-0 got the 103 and the i2c-1 the number 104

 

Thanks,

Sandro

Outcomes