AnsweredAssumed Answered

Question about project configuration and how it relates to debug_printf working...

Question asked by dave408 on May 4, 2015
Latest reply on Oct 22, 2015 by dave408

This question is completely unrelated to the other debug_printf issue I just posted a moment ago.

 

I have two projects, both setup to use PEx and MQX Standard.  One project has "debug console" as an "Inherited component" as shown below:

 

 

The other has "fsl_debug_console" as a "Shared component" as shown below:

 

 

I am pretty sure I created the projects the same way, so I must have done something different afterward, when assigning the UART.  But I don't know what I did.  The former example does not work, while the latter does.  I assume the non-working project isn't working because DbgCs1 is disabled in PEx (to get past the code generation errors due to conflicts), but I don't know how to remove fsl_uart1 and then make DbgCs1 a "shared component".  I tried to delete fsl_uart1 but it doesn't look like it's possible.  I tried to choose a different UART, but that doesn't work -- when I look at DbgCs1, KDS tells me this:

 

 

EDIT -- I just realized by changing from MQX to BareMetal and back, that one project was using MQX Standard (that's what I really want), and the other working project was using MQX Lite.  So to answer part of my question, MQX Lite "shares" the DbgCs1 component, but MQX Standard wants its own.  I vaguely recall reading something about this on the forum (I may have even responded to it...).

 

So perhaps the solution is to just leave (or delete) DbgCs1, and if that is the case, why is it that when I set up fsl_uart1 for MQX Standard that debug_printf doesn't work?  printf does work properly.

Outcomes