AnsweredAssumed Answered

Using qemu with T2080. No -cpu e6500 option

Question asked by Daniel Ruiz on Apr 27, 2015

Hello all, Im trying to run qemu for emulate a "hello world" for T2080.

 

I succesfully installed all the SDK and run host-prepare.sh script that say me everything is OK.

 

$ source ./fsl-setup-poky -m t2080rdb

$ bitbake fsl-image-virt    

 

Im trying to run:

$ ~/SDK/QorIQ-SDK-V1.7-20141218-yocto/poky/build_t2080rdb_release/tmp/sysroots/i686-linux/usr/bin/qemu-system-ppc64 - cpu e6500

And the output is :

"Unable to find PowerPC CPU definition"

I also try differentes qemu builds with no luck, for example: ~/SDK/QorIQ-SDK-V1.7-20141218-yocto/poky/build_t2080rdb_release/tmp/work/i686-linux/qemu-native/1.7.0-r0/qemu-1.7.0/ppc64-softmmu

I also check that meta/conf/bitbake.conf has the next lines:

QEMU_OPTIONS_e6500     = "-cpu e6500"

QEMU_OPTIONS_e6500-64b = "-cpu e6500"

 

If i try to boot qemu without -cpu option, qemu just freeze without any text output:

(qemu) QEMU waiting for connection on: telnet:0.0.0.0:4444,server

Warning: vlan 0 is not connected to host network

 

 

Here is the script where i try to run on qemu:

#!/bin/bash

rd=~/SDK/Target_Images/PPCE6500_Images/t2080rdb/fsl-image-core-t2080rdb.ext2.gz

kernelimg=~/SDK/Target_Images/PPCE6500_Images/t2080rdb/uImage--3.12-r0-t2080rdb-20141213024927.bin

sudo ~/SDK/QorIQ-SDK-V1.7-20141218-yocto/poky/build_t2080rdb_release/tmp/sysroots/i686-linux/usr/bin/qemu-system-ppc64  -nographic -m 256 -M ppce500 -kernel $kernelimg -initrd $rd  -append "root=/dev/ram rw console=ttyS0,115200" -serial tcp::4444,server,telnet -net nic

 

I Tried differents kernel configurations, even using qemu-system-ppc instead of 64 bits version, and i don't have any output.

 

 

Best Regards,

Daniel.

Outcomes