AnsweredAssumed Answered

Kinetis device is not being programmed

Question asked by Frederico Marcelino on Apr 6, 2015
Latest reply on Apr 10, 2015 by Kerry Zhou

Hello everyone,

 

I'm able to program a custom board with Freescale MKL05Z32. We develop a new prototype and I soldered the chip manually. Unfortunately I'm not able to program a blank microcontroller in the prototype board.

 

Things to be considered:

1) I'm shure Multilink Rev. B is ok because I can debug other (the same part number) microcontrollers.

 

2)Multilink is connected to the custom board via ribbon cable. I tested continuity with a multimeter. It seems to be ok.

 

3)I'm using a 32kHz crystal.

 

4)I tried to programm with and without 10k resistor and 100nF capacitor (all combinations) in the reset pin.

 

5)Measuring reset pin shows that microcontroller is reseting. There are 2us pulses every 34us (29,4kHz).

 

6)When I try to debug or erase whole Flash Code Warrior 10.6 opens the P&E Connection Assistent box saying that "an error ocurred while connecting to the interface hardware or target specified in the Lauch Configuration Dialog".

 

7)I try to do the steps described in this article https://community.freescale.com/docs/DOC-99609 but it didn't solve the problem. Other article were also tried without sucess.

 

8)After validating and testing the prototype, we will need a programmer for production. Actually we have Elnec but it's necessary to buy some credits for programming every single chip. We have only the Multilink for development. Is Cyclone the a good tool for this purpose?

 

Thanks,

 

Frederico

Outcomes