AnsweredAssumed Answered

Vpuenc mjpg latency seems unusually high

Question asked by Gavin Greenwalt on Mar 23, 2015
Latest reply on Apr 8, 2015 by Joan Xie

Is there a way to reduce the mjpg latency with the vpuenc path in gstreamer 0.10?     The performance seems to be very good even on the i.mx6 solo but it's about 500ms behind.  Maybe it's just my pipeline but I feel like it might be buffering internally.  Is there a no-latency flag I can enable to not buffer an input stream prior to encoding?  Seeing as mjpg is intraframe compressed I can't see any performance reasons for a buffer.   I'm writing a raw TCP stream decoder tomorrow so hopefully that'll offer even more insight into where the latency might be creeping in.   However if anyone has experience with mjpg on Freescale I would love to hear your insights. I tried using a UDPSINK and I didn't get any packets at all out and had to move to a TCPCLIENTSINK to see it spread anything. Ultimately I would like to move to UDP for multicast.

Outcomes