AnsweredAssumed Answered

FRDM KL25Z has stuck to "Programming..."

Question asked by d on Mar 20, 2015
Latest reply on Mar 23, 2015 by d

Hi everybody,

 

I have just received the FRDM KL25Z board.

Since the board comes with no debugger, I tried to drag & drop pemicro SDA debugger into FRDM board. Accidentally I drag & drop a wrong file (I even do not remember what file).

Now LASTSTAT.TXT file says “Programming”

As far as I know it should say “Ready” or something similar.

Neither codewarrior nor KDS is able to connect with KL25Z board.

They cannot even see the SDA debugger. Probably it is expected since the SDA debugger is not present in FRDM KL25Z board.

 

Also cut the line at J11 jumper and I solder a connector to J6-SWD.

I create a project for kl25z with KDS and I tried to connect with multilink universal.

At a point KDS upgrade the firmware of multilink universal. Then there was messages like “target programming”, “target program”, “target verified”, “cannot enter background mode” (I do not remember exactly).

Unfortunately no luck with multilink universal.

 

Is there a way to recover SDA debugger of my FRDM KL25Z board?

May be if LASTSTAT.TXT go away from “Programming” the FRDM KL25Z board be recovered.

 

Thank you

Outcomes