limeyguru

M54X5EVB User Flash Memory Problem

Discussion created by limeyguru on Nov 4, 2007
Latest reply on Nov 16, 2007 by Michael Norman
For some time now I have been successfully using an M54X5EVB and a custom board based on this design on one project.
 
On a second project that is using a MCF5485 FireEngine board, I found that the code flash chip (the Intel 28F128K3 "StrataFlash" chip) wasn't working correctly any more. I tried a second board and got the same results.
 
The flash chip wasn't totally dead - I could step through the CFI intructions and the status looked OK, but the flash blocks would not unlock.
 
After much hair-pulling, I finally found that by changing the ColdFire chip select settings to add 1 cycle address setup time before CS# is asserted, the chip started working!
 
Now this is puzzling me, partly because the spec sheet for the Intel 28F128K3 does not show any requirement for address setup before CS# is asserted. Also, I worked for over a year on my previous project using the flash chip with the default settings (no address setup time) and didn't see any problems.
 
Anybody have any suggestions why the flash chip should start misbehaving this way?

Outcomes