AnsweredAssumed Answered

Mass erase of factory new KL chip with SEGGER JLINK problem

Question asked by Grzegorz Kaczmarek on Mar 14, 2015
Latest reply on Mar 18, 2015 by Amit Kumar

Hello,

 

I have populated brand new KL05Z32 chip on my custom board.

Its internal 0xFF memory state prevents it from operation and causes constant reset which is visible when measuring reset signal with the scope:

SDS00001.BMP.bmp

 

It causes problems with communication to the device. Actually it is not possible to communicate (over SWD) at all:

jlink.jpg

 

I am using SEGGER JLink debugger. It works fine for other board (the same project) where KL05 was already mass erased.

I've been reading a lot on the web regarding tries of unsecuring and/or mass erasing, but nothing works for me now.

 

I've put 10k pull-up resistor on RESET line and 10k pull-down resistors on CLK and DIO lines.

It didn't changed a thing.

 

I have also tried a jlink script for unsecuring Kinetis found here:

https://community.freescale.com/thread/301600

It also changed nothing.

 

I've also tried connection from SEGGER's J-Link Commander and it tried to do mass erase also - without any luck (timeout).

 

Now my question is: what is actually a procedure for handling mass erase of the brand new chips?

I have the same problem on 3 out of 4 boards. I have no clue why it worked for the first time (without any additional resistors).

 

Thank you for your comments.

 

p.s. - after RESET signal release there is only 5[ms] before next reset signal mark.

Outcomes