AnsweredAssumed Answered

Solution shared for problems when building default C++ application

Question asked by dave408 on Mar 11, 2015
Latest reply on Mar 14, 2015 by dave408

This is just an FYI for anyone trying to get C++ projects working and for the KSDK team.  I've been struggling with the (I think) misleading g++ error message "fatal error: no input files".  It turns out that when you #include fsl_device_registers.h, you'll also end up #including processor-specific includes, depending upon which processor you have added to your preprocessor definitions.  I believe the problem with this file is that it then #includes (in my case) device/MK64F12/MK64F12.  While not necessarily a big deal, this file does appear in two different locations on the computer -- one in the KSDK_PATH, and the other in your project folder if you used the KDS New Project wizard.  Depending upon which one you pick, and what other -Includes locations you have in your toolchain settings, you may compile successfully or get that "no input files" error.

 

Hopefully this helps someone out.  Oh, and BTW there is also an Eclipse bug that also bit me -- you have to use the CDT variable ${ProjDirPath}.  ${PROJECT_LOC} will not work.

Outcomes