AnsweredAssumed Answered

TWR-LS1021A High Resolution Timer Support & RT-preempt

Question asked by Thomas T on Mar 3, 2015
Latest reply on Sep 5, 2016 by stefannickl

Hi,

 

I tried to figure out the realtime capability of the board using cyclictest. But I was not able to enable the High Resolution Timers with the QorIQ-SDK-V1.7-20141218-yocto. I enabled the kernel config for "High Resolution Timer Support" & "Fully Preemptible Kernel" support. Also I tried various other kernel settings, but every now kernel offers a resolution of 1ms, see below. Do you have a hint what to check next?

 

Best regards

Thomas

 

 

root@ls1021atwr:~# cat /proc/timer_list

Timer List Version: v0.7

HRTIMER_MAX_CLOCK_BASES: 4

now at 349411724560 nsecs

 

cpu: 0

clock 0:

  .base:       80d5b5a8

  .index:      0

  .resolution: 1000000 nsecs

  .get_time:   ktime_get

  .offset:     0 nsecs

active timers:

#0: def_rt_bandwidth, sched_rt_period_timer, S:01, start_bandwidth_timer, ksoftirqd/0/3

# expires at 350000000000-350000000000 nsecs [in 588275440 to 588275440 nsecs]

#1: <bf87dac8>, hrtimer_wakeup, S:01, hrtimer_start_range_ns, init/1

# expires at 353437111520-353442111517 nsecs [in 4025386960 to 4030386957 nsecs]

#2: <b8c8c968>, it_real_fn, S:01, hrtimer_start, syslogd/1129

# expires at 357656081120-357656081120 nsecs [in 8244356560 to 8244356560 nsecs]

clock 1:

  .base:       80d5b5e8

  .index:      1

  .resolution: 1000000 nsecs

  .get_time:   ktime_get_real

  .offset:     0 nsecs

 

...

Outcomes