AnsweredAssumed Answered

Problem building i.MX6q sabreAI fsl-image-qt5

Question asked by Stefan Huebner on Feb 24, 2015
Latest reply on Mar 31, 2015 by Rob McPherson

Hello everyone.

 

I'm trying to build an Image for the i.MX6quad automotive infotainment board.  The "simple" fsl-image-gui builds just fine.  But my application needs Qt Support (at least QtNetwork, also QtOpenGL and QtGui are used atm.).  As I did not find any Qt-related headers in the fsl-image-gui, I first tried to manually compile qt4-x11, which failed.  Then I hoped that the part of Qt I use in my application has not changed too much (I coded using Qt 4.7.1), so I tried fsl-image-qt5.  This fails with the following error:

 

Computing transaction...error: Can't install python-numpy-1.7.0-r1@cortexa9hf_vfp_neon: no package provides /bin/env


ERROR: Function failed: do_rootfs
ERROR: Logfile of failure stored in: /Daten/i.MX6/yocto/build/tmp/work/imx6qsabreauto-poky-linux-gnueabi/fsl-image-qt5/1.0-r0/temp/log.do_rootfs.14775
ERROR: Task 7 (/Daten/i.MX6/yocto/sources/meta-fsl-bsp-release/imx/meta-fsl-demos/recipes-fsl/images/fsl-image-qt5.bb, do_rootfs) failed with exit code '1'


So this looks weird to me.  util-linux should provide /bin/env, but util-linux was compiled and installed correctly, at least without any warnings or errors.


Does anybody have a solution for this?


Cheers,

Stefan

Outcomes