AnsweredAssumed Answered

Configuring an MSCAN bus on the KE06Z:  timing problems

Question asked by Nancy Neff on Feb 18, 2015
Latest reply on Feb 19, 2015 by Nancy Neff

I am trying to configure a KE06Z to talk on a CAN bus, and I'm getting error frames (reporting all types of errors, apparently randomly) and no messages (viewed with CANalyzer).  The bus is terminated at the ends with 120 ohm resistors.  Another device is broadcasting on the bus without problems or errors.  The bus rate is 250 kbit/s, therefore a bit should be taking 4 us, but is actually about 3.6 us long on the scope.  We wired up another board, and we're getting the same timing problems with it as well so it isn't a faulty transceiver on a particular KE06Z.

 

I've tried every valid combination of values for Time segment 1, Time segment 2, and Resync jump width (all 76 combinations) for 250 kbit/s, starting with letting the timing calculator choose those values for me, and I always get error frames. I've also tried auto initialization, and auto init plus enabled in init. code, and still get the error frames.  I've tried 500 kbit/s just to see if it made a difference and it doesn't; I need it to work at 250 kbit/s anyway because that's what the other device on the bus operates at.

 

I'm relatively new to both CAN and the KE06Z, so the problem might be something simple I suppose, but I'm at a loss. (I've attached a screen shot of the timing, initialization, and CPU clock/configuration set settings.)  Could it be a bug in CW for MCUs?  Any suggestions?

Attachments

Outcomes