AnsweredAssumed Answered

LS1021A TWR Network issues

Question asked by Marcus Carlberg on Feb 13, 2015
Latest reply on Sep 26, 2016 by Thomas Thorne

Trying to set up a new LS1021A at the moment, however cant seem to get the network device working properly.


I tested on the link up and got:


mdio list

FSL_MDIO:

0 - AR8031/AR8033 <--> eTSEC2

1 - AR8031/AR8033 <--> eTSEC3

2 - AR8031/AR8033 <--> eTSEC1

 

Which seems fine. If i read on the interface i get:

 

=> mdio read eTSEC1 1

mdio read eTSEC1 1

Reading from bus FSL_MDIO

PHY at address 2:

1 - 0x796d

=> mdio read eTSEC2 1

mdio read eTSEC2 1

Reading from bus FSL_MDIO

PHY at address 0:

1 - 0x7949

=> mdio read eTSEC3 1

mdio read eTSEC3 1

Reading from bus FSL_MDIO

PHY at address 1:

1 - 0x7949

Which tells me that all the ports are online.

 

However when I try to make a ping I can't reach the host.

ping -c 2 192.168.0.1

PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

From 192.168.0.55 icmp_seq=1 Destination Host Unreachable

From 192.168.0.55 icmp_seq=2 Destination Host Unreachable

 

 

--- 192.168.0.1 ping statistics ---

2 packets transmitted, 0 received, +2 errors, 100% packet loss, time 1014ms

pipe 2

 

 

My ethernet configuration looks like this for eth0:

 

4: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000

    link/ether 00:04:9f:03:63:7d brd ff:ff:ff:ff:ff:ff

    inet 192.168.0.55/24 brd 192.168.0.255 scope global eth0

       valid_lft forever preferred_lft forever

    inet6 fe80::204:9fff:fe03:637d/64 scope link

       valid_lft forever preferred_lft forever


Am I missing something, to me everything looks like it should work?

Outcomes