AnsweredAssumed Answered

i.MX28 SSP_SCK Polarity issue: Provided patch not working

Question asked by Marco Catellani on Feb 12, 2015
Latest reply on Feb 16, 2015 by Marco Catellani

Hi, I'm in trouble with the "boot from sd" issue.

I have a board that boot from ssp0 sd card. Fortunately I've a eeprom in my pcb.

I've programmed the eeprom with the freescale provided patch:

Patch for the SDK 2010.12 to fix the incorrect polarity when boot mode is set as boot from SD/eMMC on SSP0/1.

 

but the boot still fail when try to mount root fs.

 

No filesystem could mount root, tried:  ext3 ext2 vfat msdos iso9660 ntfs

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

Backtrace:

[<c00344a8>] (dump_backtrace+0x0/0x114) from [<c03f1330>] (dump_stack+0x18/0x1c)

r7:c04a59ae r6:00008000 r5:c7c16022 r4:c05663d8

[<c03f1318>] (dump_stack+0x0/0x1c) from [<c03f13ac>] (panic+0x78/0xf4)

[<c03f1334>] (panic+0x0/0xf4) from [<c000902c>] (mount_block_root+0x1d8/0x218)

r3:00000000 r2:00000020 r1:c7c27f60 r0:c04a5a55

[<c0008e54>] (mount_block_root+0x0/0x218) from [<c0009130>] (mount_root+0xc4/0xf         c)

[<c000906c>] (mount_root+0x0/0xfc) from [<c00092d4>] (prepare_namespace+0x16c/0x         1c4)

r5:c0029a29 r4:c0565760

[<c0009168>] (prepare_namespace+0x0/0x1c4) from [<c00084f8>] (kernel_init+0x128/         0x170)

r5:c0028bd8 r4:c0565520

[<c00083d0>] (kernel_init+0x0/0x170) from [<c005010c>] (do_exit+0x0/0x6dc)

r5:c00083d0 r4:00000000

 

 

Obviously the sd and the root fs is ok, I've already done all the hardware controls and I'm sure is all right. I'm sure that the boot is from eeprom, because I've controlled it with an oscilloscope.

 

I've found only a solution, if I make a reset after the kernel panic, the board reboots itself and the boot process is ok.

Anyone have a solution that works for this incredibly (no fix scheduled) problem?

 

Thanks to all in advance.

Outcomes