AnsweredAssumed Answered

SPIMaster_LDD Slave Select Always Enabled

Question asked by Tom Tatakis on Feb 2, 2015
Latest reply on Feb 13, 2015 by Marek Neuzil

Hello, I have the SynchroMaster component using the SPIMaster_LDD configured in my project with the Slave Select enabled for the component.  I do see SPI data being transmitted when I send data using SyncCAN_SendBlock().  The problem is, the Slave Select line is always low (enabled state)- even when I am not transmitting data.  Do I have to enable/disable this pin on my own even though I have set the SPIMaster component to take control of it?  If so, how do I toggle this bit?

 

I running this through CodeWarrior on the FRDM-KL25Z board.

 

Thanks for any help.

Tom

Outcomes