AnsweredAssumed Answered

"No GSettings schemes are installed on the system" error when running gnome-bluetooth on i.MX6Q SABRE SD

Question asked by Alvin Dizon on Jan 30, 2015
Latest reply on Feb 4, 2015 by Alvin Dizon

Hello everyone,

 

I bitbaked the recipe "gnome-bluetooth", which produced four binaries, namely bluetooth-applet, bluetooth-properties, bluetooth-wizard, and bluetooth-sendto. I transferred the contents of the gnome-bluetooth's "image" folder into their corresponding folder hierarchy in the target filesystem, so that the shared libraries and other related files are in their proper folder in the target. Now when I tried running the "bluetooth-applet" binary, the following error appeared:

 

"GLib-GIO-ERROR: No GSettings schemes are installed on the system. Trace/breakpoint trap"

 

The same error also appeared when I tried to run bluetooth-properties. Strangely enough, the remaining two binaries bluetooth-sendto and bluetooth-wizard can start. I was wondering if anyone has used the gnome-bluetooth manager for their board, and if anyone also encountered the same error. I know I did a mistake somewhere in the process, but I would appreciate if anyone can point me in the right direction. BTW,  my host platform is an x86 64 bit PC with Ubuntu 12.04 LTS.

 

Thank you!

Outcomes