AnsweredAssumed Answered

FRDM-KL46Z can't enter debug mode

Question asked by Su on Jan 23, 2015
Latest reply on Jan 23, 2015 by ZhangJennie

Hello, my FRDM-KL46Z can't enter debug mode now, it worked well before. I've reloaded the "DEBUG-APP_Pemicro_v108.SDA", but it doesn't work. And if I switch to "MSD-FRDM-KL46Z48M_Pemicro_v113.SDA", it can work well.

 

Additional, the computer can found the OPEN SDA(please find the enclosed picture). But if I try to enter debug mode, the error come out.

The error information as below:(I use KDS 2.0),

-----------------------------------------------------------------------------------------------------------------------------------------------------

P&E GDB Server, Version 5.13.02.00

Copyright 2014, P&E Microcomputer Systems Inc, All rights reserved

 

 

Loading library C:\Freescale\KDS_2.0.0\eclipse\plugins\com.pemicro.debug.gdbjtag.pne_1.1.7.201410171532\win32\gdi\unit_ngs_arm_internal.dll ... Done.

 

 

Command line arguments: -device=KL46Z256M4 -startserver -singlesession -serverport=7224 -interface=OPENSDA -speed=5000 -resetdelay=200 -port=USB1 -USE_CYCLONEPRO_RELAYS=0 -FORCE_MASS_ERASE=0

Device selected is kl46z256m4

User Specified Hardware Selection : Interface=OPENSDA and Port=USB1

Connecting to target.

Error opening selected communication interface

 

 

Error - Port not found.

 

 

 

 

 

 

Can not enter background mode  .

 

 

 

 

 

 

Unable to initialize PEDebug.

 

 

PE-ERROR: Failed to Initialize Target

PE-ERROR: EXCEPTION : Could not bind socket. Address and port are already in use.

PE-ERROR: Unable to start server with the settings provided. Halting.

Target Disconnected.

 

-----------------------------------------------------------------------------------------------------------------------------------------------------

Attachments

Outcomes