AnsweredAssumed Answered

yocto wi-fi with wl12xx

Question asked by michaeldiamond on Jan 22, 2015
Latest reply on Jan 27, 2015 by michaeldiamond

Has anyone gotten the WIFI on the nitrogen6x to work with yocto?  We have a custom board that is loosly based on the nitrogen6x that has worked in LTIB.  We have used wifi with the LTIB images but are now just switching to yocto dizzy with an updated kernal(Starting with version3.10.17-1.0.2). All the documentation we read said the wifi works but we have had no success.

We have tried the default image from boundary devices on the nitrogen 6x and this is what happens.  When we try to bring up the wlan0 (ifconfig wlan0 up) we get the message

ifconfig: SIOCSIFFLAGS: Operation not possible due to RF-kill.

We noticed that the kernel module is no longer wl12xx_sdio and am not sure what else has changed. We see the kernel module wl12xx, wcore and wcore_sdio.  We have tried to modprobe all three of those.  When we try to set the essid we get the following error;
Cannot read /proc/net/wireless
Error for wireless request “Set ESSID” (8B1A) :
SET failed on device wlan0 ; Invalid argument.

What are we missing?  Being brand new to yocto and the updated kernel with device tree we have surely missed something.

Outcomes