AnsweredAssumed Answered

Need help getting started with CodeWarrior 10.6

Question asked by John Cook on Jan 1, 2015
Latest reply on Jan 3, 2015 by ZhangJennie

Help!

 

I'm trying to get started with an example project with CodeWarrier 10.6 and I've had lots of trouble.

 

I figured I'd take the easy path and use a demo board, load the project that goes with it, and start messing around.

 

So I got the TWR-S08DC-PT60 and Codewarrir 10.6 eval version (with all the latest patches) and downloaded the example project that goes with the board.

 

Problems galore!  It took me hours to dig out how to import a project because there were several "gotchas" in there.  I finally figured out that if I created a new, blank folder (ie workspace) and imported the example into that then I could actually load the project.  No, I could not just load the project from where I downloaded and unzipped it!   Grrr!

 

Now I cannot make the project.  Build, yes.  Make, no.  I get a "no rule to make target" error.  I read the help for hours to find out I had to create a target to make and did that.  Then I got an error that there was no rule to make my new target name.  So how the heck do I make a rule to make this target?  Isn't that supposed to part of the downloaded example?  I tried to look up how to make a rule but there was nothing.

 

I've tried several times to get started with this new Eclipse environment and I keep having tons of troubles.  The old IDE that I started with years ago was nothing like this!  It was simple and it worked!

 

I'm so frustrated with this overly complicated hunk of junk I'm thinking of changing over to Atmel micros instead.

Outcomes