AnsweredAssumed Answered

why does "make clean" with "Parameter format not correct"?

Question asked by Phil Anderson on Dec 30, 2014
Latest reply on Jan 2, 2015 by Phil Anderson

Using KDS 2.0.0 with TWR-KL25Z48M

Imported the "helloworld" project (using PEX, since apparently KSDK support isn't ready yet?)

Had to do a bunch of prodding to shake out all the IAR settings and get them to GCC instead, but one that's been bugging me is that the "clean" option doesn't work - I get the following error:


make clean

del  ./Sources/Events.o ./Sources/ProcessorExpert.o  ./Project_Settings/Startup_Code/startup.o  ./Generated_Code/Blue_LED.o ./Generated_Code/Cpu.o ./Generated_Code/CsIO1.o ./Generated_Code/Green_LED.o ./Generated_Code/IO1.o ./Generated_Code/PE_LDD.o ./Generated_Code/Red_LED.o ./Generated_Code/Vectors.o  ./Sources/Events.d ./Sources/ProcessorExpert.d  ./Project_Settings/Startup_Code/startup.d  ./Generated_Code/Blue_LED.d ./Generated_Code/Cpu.d ./Generated_Code/CsIO1.d ./Generated_Code/Green_LED.d ./Generated_Code/IO1.d ./Generated_Code/PE_LDD.d ./Generated_Code/Red_LED.d ./Generated_Code/Vectors.d  helloworld.srec  helloworld

Parameter format not correct - "Sources".

make: [clean] Error 1 (ignored)


I notice that PEX (or whatever is responsible for generating the makefile) is adding the alias

  rm := del

at the beginning, I can't figure out how to change that. But I'm guessing that "del" doesn't like the ./directory/filename.o format and would prefer the ".\directory\filename" instead.


Any ideas? It's not a show-stopper since incremental builds still work well enough but it's kind of silly to not have "clean" work.