AnsweredAssumed Answered

MQX 3.8 Compatibility with CodeWarrior 10.6 - Reliable Controls

Question asked by Jim.Carlson Employee on Dec 18, 2014
Latest reply on May 11, 2016 by Evgeny Erlihman

Hello MQX/CW team,

 

My customer, Reliable Controls in Canada, asked this question (they are using the MCF5225 and the MCF5271 in two projects):

 

We would like to update our CW 10.2 projects that are in active development to CW 10.6; and this is where we’re seeing a problem.  We have done this and everything is working except that we are having an issue debugging MQX 3.8 with CW 10.6 (https://community.freescale.com/message/463251#463251).  We see now that the CW 10.6 release notes say that it doesn’t support MQX 3.8, but we would like to find out exactly why this is and what we can do to overcome this limitation; making a couple of changes to MQX 3.8 would be preferred for us rather than moving to MQX 4.1.

 

To that end, could you please put me in touch with someone that can provide some information on why CW 10.6 is not supporting MQX 3.8, and specifically why we are unable to debug MQX 3.8 using CW 10.6 software breakpoints?

 

Thank you for any help that you can provide.

--

Regards,

Jim

Outcomes