AnsweredAssumed Answered

Xserver OpenGL Question (3.10.31-Beta)

Question asked by John Reep on Dec 18, 2014
Latest reply on Jan 9, 2015 by A Thomas
Branched to a new discussion

Has anyone looked into the latest Vivante Drivers for use with the 3.10.31 Kernel?  I have been developing with Debian 8 on an i.MX6.  I have built the Kernel 3.10.31-Beta2 from the sources provided by Freescale.  I used a prior version of the DTS files for the 3.10.17 Kernel and updated them for respective changes to enable the feature sets that I ultimately want.  I have spent most of this week working with X-Server.  I have basically gone through and compiled from the sources the entire X-server on target including libDRM and MESA on target.  I am still having an issue where the X desktop environment comes up and if I try to run anything to do with openGL then I receive the following message:

 

Error: couldn't find RGB GLX visual or fbconfig

 

I receive this message when trying to operate the Mesa Utils: glxinfo and glxgears.  I have previously worked with 3.10.17_ga and was able to have the vivante drivers install.  However, the installation where it worked I could get glxinfo to report the GC2000 but glxgears would not work at all.  In fact, the system would hang.  Because of this issue, I decided to attempt a from scratch build up to determine what the best course could be.

 

I have attached the Xorg.1.log file that has been saved based on this build environment.  A couple items that bother me:  Should I be seeing so many "drmOpenDevice" flags that seem to be attempting to be loading /dev/dri/card*?  And: Should I be seeing a line which is:

 

GLX: no usable GL providers found for screen 0


If either of these is a non-issue, I would appreciate a head's up.  I was pretty certain I should be able to get the hardware accelerated X + Open GL capability up and running.  I will add that I have been able to run all of the non-X related Examples provided in the viv_samples from the gpu-viv-bin-mx6q-3.10.31-1.1.0-beta-hfp demonstrations.  This requires the symlinks in /usr/lib to be pointed to the correct -fb libraries.  Is there anything else that I should be doing?  Is this a function of attempting to use Xorg 1.14.?  I only chose this because it seems like it should be possible?

 

Thanks in advance for any help or input,

John

Original Attachment has been moved to: xorg-data.txt.zip

Outcomes