AnsweredAssumed Answered

Android 5.0 on iMX6Q

Question asked by Damien Dejean on Dec 11, 2014
Latest reply on Dec 16, 2014 by igorpadykov

Hello Community !

 

I'm trying to port Android 5.0 to a board based on iMX6Q processor with Vivante Vivante GC2000 GPU. Im' facing the followin crash during the boot:

 

D/OpenGLRenderer( 2931): Render dirty regions requested: true

D/Atlas   ( 2931): Validating map...

D/PhoneStatusBar( 2931): disable: < expand icons alerts system_info back home recent clock search >

E/BluetoothAdapter( 2931): Bluetooth binder is null

D/PhoneStatusBar( 2931): heads up is enabled

I/art     ( 2931): Clamp target GC heap from 19MB to 16MB

E/BufferQueueProducer( 2274): [com.android.systemui.ImageWallpaper] dequeueBuffer: can't dequeue multiple buffers without setting the buffer count

I/Choreographer( 2931): Skipped 67 frames!  The application may be doing too much work on its main thread.

D/ViewRootImpl( 2931): changeCanvasOpacity: opaque=true

I/OpenGLRenderer( 2931): Initialized EGL, version 1.4

D/OpenGLRenderer( 2931): Enabling debug mode 0

E/BufferQueueProducer( 2274): [StatusBar] dequeueBuffer: can't dequeue multiple buffers without setting the buffer count

D/WifiService( 2834): New client listening to asynchronous messages

D/OpenGLRenderer( 2931): setting property extraRasterBucket to 0.95

D/OpenGLRenderer( 2931):     failed

D/OpenGLRenderer( 2931): setting property extraRasterBucket to 0.0

D/OpenGLRenderer( 2931):     failed

E/BufferQueueProducer( 2274): [StatusBar] dequeueBuffer: can't dequeue multiple buffers without setting the buffer count

F/OpenGLRenderer( 2931): Encountered EGL error 12299 EGL_BAD_NATIVE_WINDOW during rendering

F/libc    ( 2931): Fatal signal 6 (SIGABRT), code -6 in tid 3227 (RenderThread)

I/DEBUG   ( 2277): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***

I/DEBUG   ( 2277): Build fingerprint: 'BT-Ground/btbox/btbox:5.0/LRX21V/ddejean12041005:userdebug/test-keys'

I/DEBUG   ( 2277): Revision: '405522'

I/DEBUG   ( 2277): ABI: 'arm'

I/DEBUG   ( 2277): pid: 2931, tid: 3227, name: RenderThread  >>> com.android.systemui <<<

I/DEBUG   ( 2277): signal 6 (SIGABRT), code -6 (SI_TKILL), fault addr --------

I/DEBUG   ( 2277): Abort message: 'Encountered EGL error 12299 EGL_BAD_NATIVE_WINDOW during rendering'

E/DEBUG   ( 2277): AM write failure (32 / Broken pipe)

I/DEBUG   ( 2277):     r0 00000000  r1 00000c9b  r2 00000006  r3 00000000

I/DEBUG   ( 2277):     r4 4c515db8  r5 00000006  r6 00000002  r7 0000010c

I/DEBUG   ( 2277):     r8 4bd012ac  r9 4c515d08  sl 400ff5c9  fp 4c515db0

I/DEBUG   ( 2277):     ip 00000c9b  sp 4c5157c8  lr 400ffe01  pc 40123c18  cpsr 600f0010

I/DEBUG   ( 2277):

I/DEBUG   ( 2277): backtrace:

I/DEBUG   ( 2277):     #00 pc 0003ac18  /system/lib/libc.so (tgkill+12)

I/DEBUG   ( 2277):     #01 pc 00016dfd  /system/lib/libc.so (pthread_kill+52)

I/DEBUG   ( 2277):     #02 pc 00017a1b  /system/lib/libc.so (raise+10)

I/DEBUG   ( 2277):     #03 pc 00014271  /system/lib/libc.so (__libc_android_abort+36)

I/DEBUG   ( 2277):     #04 pc 00012a40  /system/lib/libc.so (abort+4)

I/DEBUG   ( 2277):     #05 pc 00007b65  /system/lib/libcutils.so (__android_log_assert+88)

I/DEBUG   ( 2277):     #06 pc 0003cae5  /system/lib/libhwui.so

I/DEBUG   ( 2277):     #07 pc 0003b589  /system/lib/libhwui.so

I/DEBUG   ( 2277):     #08 pc 0003b745  /system/lib/libhwui.so

I/DEBUG   ( 2277):     #09 pc 0003c631  /system/lib/libhwui.so

I/DEBUG   ( 2277):     #10 pc 0003e12f  /system/lib/libhwui.so (android::uirenderer::renderthread::RenderThread::threadLoop()+66)

I/DEBUG   ( 2277):     #11 pc 00010531  /system/lib/libutils.so (android::Thread::_threadLoop(void*)+112)

I/DEBUG   ( 2277):     #12 pc 0005e035  /system/lib/libandroid_runtime.so (android::AndroidRuntime::javaThreadShell(void*)+72)

I/DEBUG   ( 2277):     #13 pc 000100a1  /system/lib/libutils.so

I/DEBUG   ( 2277):     #14 pc 000165e7  /system/lib/libc.so (__pthread_start(void*)+30)

I/DEBUG   ( 2277):     #15 pc 000145db  /system/lib/libc.so (__start_thread+6)

I/DEBUG   ( 2277):

I/DEBUG   ( 2277): Tombstone written to: /data/tombstones/tombstone_03


I'm trying to determine waht should change or what I missed to avoid this crash. Could you help me ?


Thanks,


Damien.

Outcomes